V4.3.0I - Authentification 2 facteurs

Nouvelles versions, nouvelles fonctionnalités...

Modérateur: Weezo

V4.3.0I - Authentification 2 facteurs

Message par Weezo » Jeu 14 Nov, 2013 19:01

Bonjour à tous,

La version I est en ligne.

La sécurité a été renforcée grace à la possibilité d'utiliser une authentification 2 facteurs pour se connecter à son compte.

Pour cela il vous faudra sélectionner l'option dans la configuration du groupe, télécharger une application compatible (Google Authenticator par exemple), et scanner le QR Code pour échanger la clé secrète.
Vous devrez alors utiliser un code unique à chaque connexion - il est néanmoins possible sur un pc ou un mobile de confiance de choisir de ne plus entrer ce code.

En plus de cela, il est maintenant possible de mémoriser les mots de passe sur la page de connexion. Cette fonctionnalité arrive certes un peu tard, mais elle était un peu technique à mettre en place à cause de l'adresse IP d'un site qui peut changer, et qui ne permet donc pas l'utilisation de cookies.

La 4.3.0I fait aussi évoluer le thème sur mobile, upgrade PHP en version 5.4.21, corrige un problème sur le menu contextuel Weezo de Windows lorsque Weezo est lancé avec les privilèges admin, un problème de log dans l'interface utilisateur, et améliore l'algorithme de génération des nombres aléatoires.

Le problème de mise à jour des versions de dev devrait aussi être corrigé.

Téléchargement sur http://dev.weezo.net
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0I - Authentification 2 facteurs

Message par Gil » Lun 18 Nov, 2013 15:54

Salut Weezo
Pas de MAJ auto depuis une version 4.3.0H
Gil
Membre
 
Message(s) : 167
Inscription : Mar 19 Jan, 2010 9:31
Localisation : Normandie

Re: V4.3.0I - Authentification 2 facteurs

Message par Weezo » Lun 18 Nov, 2013 21:37

Je suppose que la mise à jour des versions beta est bien sélectionnée ?
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0I - Authentification 2 facteurs

Message par Gil » Mar 19 Nov, 2013 6:52

Oui bien sur. J'ai fait une MAJ manuelle.
L'affichage du ping toutes les 3 secondes ne s'affiche plus dans le journal :)
Gil
Membre
 
Message(s) : 167
Inscription : Mar 19 Jan, 2010 9:31
Localisation : Normandie

Re: V4.3.0I - Authentification 2 facteurs

Message par yorel » Mar 26 Nov, 2013 14:25

merci pour cette nouvelle mouture, je n'ai plus d'affichage du ping.
j'ai quand même un affichage au lancement :
"le point d'entrée de la procédure php_checkuid est introuvable dans la bibliothèque de liens dynamiques php5ts.dll" et ce après une mise à jour, ça ne se produit pas après une install vierge sur une nouvelle machine.
est-ce un lien manquant ?
De toute façon, merci pour cette nouvelle version.
Yorel
yorel
Membre
 
Message(s) : 33
Inscription : Ven 30 Mars, 2007 8:37
Localisation : Essonne

Re: V4.3.0I - Authentification 2 facteurs

Message par pinkfloyd » Mer 27 Nov, 2013 5:24

"le point d'entrée de la procédure php_checkuid est introuvable dans la bibliothèque de liens dynamiques php5ts.dll"

idem ici :D
pinkfloyd
Membre
 
Message(s) : 31
Inscription : Mar 19 Déc, 2006 15:34

Re: V4.3.0I - Authentification 2 facteurs

Message par Weezo » Ven 29 Nov, 2013 7:10

C'est la version 5.4 de PHP qui est sélectionnée dans les prefs du serveur ?
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0I - Authentification 2 facteurs

Message par Weezo » Ven 29 Nov, 2013 8:07

Et c'est sous quelle version de windows ?
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0I - Authentification 2 facteurs

Message par yorel » Ven 29 Nov, 2013 9:33

Sur la machine qui pose pb Windows 7 et PHP5.4 (avec php5.2) pas de pb.
sur la machine nouvelle sans pb windows 8 et php5.4
Encore merci... tout roule maintenant

Yorel
yorel
Membre
 
Message(s) : 33
Inscription : Ven 30 Mars, 2007 8:37
Localisation : Essonne

Re: V4.3.0I - Authentification 2 facteurs

Message par pinkfloyd » Dim 08 Déc, 2013 12:07

Windows 7 x64 et PHP5.4 aussi
pinkfloyd
Membre
 
Message(s) : 31
Inscription : Mar 19 Déc, 2006 15:34

Re: V4.3.0I - Authentification 2 facteurs

Message par Weezo » Ven 13 Déc, 2013 7:37

Bonjour,
Est-ce que la dernière version (J) a corrigé le problème PHP ?
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0I - Authentification 2 facteurs

Message par yorel » Ven 13 Déc, 2013 9:50

Non, malheureusement, le probleme est identique sur 2 PC Windows 7 (64bits), mais ça marche toujours en php5.2
donc peut etre pas resolu d'un point de vue technuique, mais point de vue pratique tout marche.
Encore merci et passe de bonnes fêtes

Yorel
yorel
Membre
 
Message(s) : 33
Inscription : Ven 30 Mars, 2007 8:37
Localisation : Essonne


Retour vers Nouveautés

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron