V4.3.0B - Interface distante

Nouvelles versions, nouvelles fonctionnalités...

Modérateur: Weezo

V4.3.0B - Interface distante

Message par Weezo » Jeu 11 Juil, 2013 17:11

Bonjour à tous.

La version 4.3.0B pour Windows est disponible.

La grosse nouveauté est la possibilité d'accéder à distance à l'interface utilisateur.
Cela se fait sous la forme d'un nouveau partage, accessible uniquement au groupe administrateur.

La mise en place de cette fonctionnalité a eu énormément d'impacts sur le programme, d'où le délai assez long depuis la dernière version.
Avec toute évolution majeure viennent inévitablement des bugs. Normalement tout ça a bien été testé mais on n'est pas à l'abris.

Cette fonctionnalité est indispensable aux évolutions future de Weezo...

Téléchargement sur http://dev.weezo.net
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0B - Interface distante

Message par Zoic22 » Ven 12 Juil, 2013 18:36

Bonjour,

Deja merci pour cette nouvelle version malheureusement je n'arrive pas à la faire marcher chez moi (Ubuntu server 13.04) j'ai essayé le .deb (qui d'ailleurs lors de l'installation dit weezo 4.3.0.A est bien installé au lieu de B) et la version portable (en x64) mais dans les 2 cas j'ai le même message d'erreur (pour le .deb j'essaye de lancer /usr/bin/weezo et pour la version portable weezo.sh) :
weezo: cannot connect to X server

Mais en relisant ton message, je pense que c'est dû au fait que pour le moment seul la version Windows est disponible sans interface ?
Zoic22
Membre
 
Message(s) : 136
Inscription : Mar 24 Fév, 2009 10:01

Re: V4.3.0B - Interface distante

Message par Weezo » Dim 14 Juil, 2013 21:05

Non non, c'est bien pour linux. Par contre il ne faut pas lancer weezo, mais weezo.nogui
Attention de bien mettre la version 4.3.0B qui est en ligne en ce moment.
Et pour l'instant il y a un bug avec la version .deb : pour que ça marche il faut lancer weezo.nogui en tant qu'admin
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0B - Interface distante

Message par Zoic22 » Lun 15 Juil, 2013 9:06

Bonjour,

Je pense il y a une problème avec la version portable x64 elle fait 158mo (au lieu de 39mo pour la version 32) et surtout contient des .deb des dossier update des dossier qui ont l'air de contenir la version 32bits de weezo...
Zoic22
Membre
 
Message(s) : 136
Inscription : Mar 24 Fév, 2009 10:01

Re: V4.3.0B - Interface distante

Message par Weezo » Lun 15 Juil, 2013 17:05

La mise en ligne des versions linux est automatisée, et pour l'instant pas au point.
C'est pour ça que seule la version Windows était annoncée.
Mais une version linux correcte devrait très bientôt arriver.
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0B - Interface distante

Message par Zoic22 » Lun 15 Juil, 2013 17:33

Je viens de tester avec la version 32 bits et lorsque je lance le weezo.nogui j'ai le droit à :
[19:32:55] root:bin # ./weezo.nogui
zsh: aucun fichier ou dossier de ce type: ./weezo.nogui

Idem si je lance le weezo.sh à la racine ou le weezo normale. Un peu étrange comme erreur sachant que les fichiers sont bien la.
Zoic22
Membre
 
Message(s) : 136
Inscription : Mar 24 Fév, 2009 10:01

Re: V4.3.0B - Interface distante

Message par Zoic22 » Lun 15 Juil, 2013 17:58

Après test de la version deb 64 celle-ci s'installe correctement et après corrigé des petits problèmes de droit j'arrive à lancer weezo enfin il n'y plus d'erreur en ligne de commande, j'ai bien l'acceptation de la licence puis la demande pour le mot de passe administrateur, mais impossible d'accéder à l'interface. Petite particularité j'ai déjà un serveur web qui tourne sur le port 80 j'ai donc dans bin/default/general.ini changé serverPort = 80 par serverPort = 8083, mais rien sur le port 8083 (et dans netstat aussi) j'ai oublié quelque chose quelque part ? Où se trouvent les logs ?
Zoic22
Membre
 
Message(s) : 136
Inscription : Mar 24 Fév, 2009 10:01

Re: V4.3.0B - Interface distante

Message par Zoic22 » Lun 15 Juil, 2013 18:10

Je continue mes péripéties. J'ai trouvé les logs et une premières erreur avec libexpat, ajout d'un lien symbolique et c'était bon :
ln -s /lib/x86_64-linux-gnu/libexpat.so.1 /lib/x86_64-linux-gnu/libexpat.so.0

Et la miracle weezo démarre (sur le port 8082 alors que j'ai dit dans la conf 8083) mais j'ai accès à l'interface. Par contre impossible de me connecter en administrateur il me dit que mon mot de passe est pas bon (je suis quasiment sur qu'il est valide vu que je l'ai encore sur ma console ssh) un moyen de le réinitialiser ?
Zoic22
Membre
 
Message(s) : 136
Inscription : Mar 24 Fév, 2009 10:01

Re: V4.3.0B - Interface distante

Message par Weezo » Mar 16 Juil, 2013 16:35

Pour l'instant le seul moyen est d'éditer le fichier .usr situé dans data/groups et de modifier le champ password.
Il est normalement possible de mettre comme valeur clear:toto ou alors sha1:XXX (ou XXX est le sha1 du mot de passe).
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0B - Interface distante

Message par Zoic22 » Mar 16 Juil, 2013 18:04

Bonjour,

Meme après avoir modifier le mot de passe à la main toujours le même problème l'interface me dit que mon mot de passe est invalide. Mon fichier account0.usr :
; Automaticaly generated file
; Manual modifications might (or might not) be erased...
;
IPFilterExcluded =
id = 3TWPS4Ff1b
noPopup = true
authenticationMethod = password
subType = ui
comments = false
name = Administrateur
IPFilterIncluded = 127.0.0.1;10.*.*.*;192.168.*.*
audioProfile = default
password = clear:toto
locked = true
IPFilter = include
accountType = singleUser
administrator = true
icon = net.jpg
commentsPanelSate = 1
type = administration
activated = true
configFilename = account0.usr

[resource0]
file = administrationstd1.res
type = administration
subType = std

[resource1]
file = explorerFile11.res
type = explorer
subType = File1


Merci pour ton aide
Zoic22
Membre
 
Message(s) : 136
Inscription : Mar 24 Fév, 2009 10:01

Re: V4.3.0B - Interface distante

Message par Zoic22 » Mar 16 Juil, 2013 18:16

Après avoir un peu bidouiller le fichier (suppression de l'authentification par mot de passe, j'ai une authentification ldap avant weezo, et ajout de mon ip dans la liste des autorisées) j'arrive à me connecter en administrateur par contre la ressource d'administration ne permet pas d'administrer weezo (seulement suivi et gestion, contact, transfert en cours et statistique) il y a un paramètre à mettre pour débloquer toute l'administration ?
Zoic22
Membre
 
Message(s) : 136
Inscription : Mar 24 Fév, 2009 10:01

Re: V4.3.0B - Interface distante

Message par Weezo » Mar 16 Juil, 2013 20:56

Effectivement il n'y a pas le partage "interface utilisateur".
Je constate aussi le problème ici.
J'ai déjà corrigé pas mal de problèmes, je rajoute celui-là à la liste et je diffuse rapidement le correctif.

Par contre je propose de continuer la discussion dans la section linux, plus adaptée.
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0B - Interface distante

Message par Weezo » Mar 16 Juil, 2013 21:00

Et en attendant, pour dépanner, en fin de fichier account0.usr il faut ajouter :
[resource2]
file = administrationui1.res
type = administration
subType = ui
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Re: V4.3.0B - Interface distante

Message par Zoic22 » Jeu 18 Juil, 2013 10:35

Bonjour,

Après la modification j'ai bien accès a la console d'administration merci!!!!!!!

Par contre petit bug (commun à toute les versions je pense d'ou mon post sur ce thread) : dans l'édition d'un partage de type fichier je ne peux que éditer le nom de celui-ci aucune modification possible des autre champs. Dans la console de chrome j'ai les erreurs suivantes :
Uncaught SyntaxError: Unexpected token < wz_dragDrop.js:1
Uncaught ReferenceError: SCROLL is not defined index.php?resId=2&rnd=0.218042038846761:254
Zoic22
Membre
 
Message(s) : 136
Inscription : Mar 24 Fév, 2009 10:01

Re: V4.3.0B - Interface distante

Message par Weezo » Jeu 18 Juil, 2013 20:07

Je pense que ce bug a été corrigé sur la version linux. Normalement il ne se produit qu'après avoir cliqué au moins une fois sur l'abre des utilisateurs / partages de gauche non ?
Weezo
Tôlier
 
Message(s) : 7364
Inscription : Mar 14 Nov, 2006 10:42

Suivant

Retour vers Nouveautés

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron